This article covers troubleshooting steps for the new Spectrum TV app on Roku. If you need general support for the app, you can find it here.

Troubleshooting

Below are basic troubleshooting steps for the new Spectrum TV app on Roku. If you have questions or need help with your Roku, please visit Roku support   .

If you need to reboot the new Spectrum TV app on Roku, do the following:

  1. Exit the new Spectrum TV app on Roku completely.
  2. Relaunch the new Spectrum TV app on Roku to see if the issue is still occurring.
  3. Reboot your Roku. Unplug it, wait 30 seconds, then plug it back in.
  4. Remove and re-install the new Spectrum TV app.

Issues and Solutions

 

Issue Recommended steps:

Username or password incorrect

  1. If you have a Spectrum email account, try using your full username (including @charter.net).
  2. Ensure that you're using the correct Spectrum username and password. Note: Passwords are case sensitive. You can change case and symbols by selecting from the three pages (abc, ABC, #&%) above the virtual keyboard.
  3. If you haven't created a username/email address, get Spectrum.net sign-in help.

No picture

  1. Verify the TV is on the correct input (Video 1, HDMI, etc.) by pressing Input, Source, or TV/Video on your TV's remote control.
  2. Confirm the Roku and TV have power and are powered on.
  3. Verify that your Roku is connected to your internet, using either a wired or wireless connection. Learn more.
  4. Unplug and re-plug your HDMI cable.
  5. Reboot your Roku. Unplug it, wait 30 seconds, then plug it back in.
  6. See Roku support   .

Picture quality/buffering

Note: After changing channels, it can take up to 60 seconds for the picture to adjust to higher quality.

  1. Check your network connection on Roku:
    1. Press the Home button.
    2. Open Settings.
    3. Open Network.
    4. Select Wireless (WiFi) or Wired (Ethernet) depending on your connection type.
    5. Select Update Connection for status.
  2. Troubleshoot your WiFi network.
  3. Visit Roku support   .

No audio/low audio

  1. Check the volume level on your TV.
  2. Unplug and re-plug your HDMI cable.

Slow channel tune times

Reset your modem:

  1. Unplug the power cord from the back of the modem and remove any batteries.
  2. Wait 30 seconds, then reinsert any batteries and reconnect power to the modem.